Find us on Google+ Can't Select Threads in Autodesk Inventor? Check the Registry! ~ Inventor Tales

Thursday, March 13, 2014

Can't Select Threads in Autodesk Inventor? Check the Registry!


“The stitch is lost unless the thread be knotted”
Italian Proverb

Every once in a while, I run into something that in all my years of using Autodesk Inventor, I've never seen before.

And I just recently ran into one of those cases.  I encountered an Inventor installation that was doing something I had never seen before.  Using Inventor for nearly 15 years, this one was totally new.

On this particular machine, threads couldn't be added.  The hole tool would start just fine, but when I tried to select threaded holes, nothing happened.  The radio button wouldn't select.  It was like the button wasn't there.

Threads cannot be selected!
Not having seen this before, I do what any self respecting geek would do.  I fired up Google and began a search!

Fortunately, my search paid off, and I found a link with a solution!  I can't take the credit for finding the solution, but what I can do, is share what I've discovered!

Credit goes to JD Mather who put up the solution originally!
  • The first thing I do, is shut down Inventor.  I don't think this is necessary, but it's a good practice, and I don't take chances.  
 
  • Next type REGEDIT in the Windows Search box.  This opens the Windows Registry Editor. 



  • Once the registry editor is opened, browse to the following key: HKEY_CURRENT_USER\Software\Autodesk\Inventor\RegistryVersion 1X.0\System\Preferences\Part  
    • Locate the key: UseExcelToReadThreadFile
    • Note! The value for 'X' varies based on which version of Inventor is being used.  (This example is Inventor 2014)



  • After locating the key, right click on it, and choose Modify



  • Change the value from 0 to 1


  • Once this value is changed, close the Registry Editor, and start up Inventor. 

After that was done, the computer could place threads just fine!



This was really an odd one, I've never seen it, but feel free to drop a comment if you have.  I'm curious to see if this has shown up for anyone else out there!

Acknowledgements!!!!

I'd love to say that I came up with this solution all on my own.  But I didn't.  Thanks again to JDMather.  He placed a great update at the following link on the Autodesk Discussion Group.

All I can say is that I updated some of the info, and added some updated images.

I definitely have to give credit where credit is due!

5 comments:

  1. Thank You for posting. I am facing the same problem and shall rectify with your proposed solution and help.
    Regards

    ReplyDelete
    Replies
    1. I'm glad the tip helped! Happy Inventing!

      Delete
  2. Thanks, from One of a self respecting geek like you....

    ReplyDelete
    Replies
    1. Quite welcome! I hope this solution helped!

      Delete
  3. Thanks, From one of the self respecting geek like you.... ;)

    ReplyDelete